「Unable to execute dex: Multiple dex files define」

始まりは、この1行だった。

新しいアプリをアップしようと
いそいそとapk発行を試みたら
最後の最後でこのメッセージが出て
失敗しちゃうんだよね。

4ヶ月前に初チャレンジしたときは
すんなりいったのに。なぜ????

…と、どつぼにはまっております。

どーやら、sdkのバージョンアップにかかわっているようで。
レベル14あたりから大幅な変更があったとかで
バージョンアップしないとならないらしい。という結論で。

じゃ、アップしてやろーじゃないの!
と、久々にSDKマネージャーでバージョンアップを試みたものの

「sdk manager failde to install」

と、ここでもエラーぶっちゃって。

文系の最大のネックは環境設定なんだよなぁ。

えらく行き詰って仕方なく
他のパソコンで新たにeclipseをインストールしてSDKをインストールして…
と、やって新たにインストールしたEclipseを起動させてみたら、ずいぶん景色が違うじゃないの!

LogCatも、いままでなじんでたマークの横には(推奨しない)ってコメントがあるし。
SDKマネージャーと、AVDマネージャーが分かれちゃってるし。

でもさ。
その新しい環境で、
旧環境でつくったアプリを起動させようとすると
またしてもエラーが出ちゃうんだよなぁ。

日本androidの会にも「apk発行の際に失敗する」というトビがあがっていて
プログラマーな方達の中にも
はまっちゃってる人がいるみたいだし。

あ~~~~~

一度通った道でも
新たなチャレンジになっちゃうのね。

4ヶ月前のことは、ムカシ、ムカシ…
もう、使い物にならない情報だって。

アタシはやっぱりお門違いの世界に足を突っ込んでるのかなぁ。
…と、こんなときは、弱気になっちゃう。

でも、せっかく作ったアプリ。
アップさせたい~~~~!!!